Unable to upgrade to version 4

Hi,

I have successfully upgraded my test server from 3.2.6-1 to 4.0.1 following the manual. However my production server running exactly the same configuration (Debian 10.6, MongoDB 4.2.11, Elasticsearch 7.10.0) tells me that that I have already the latest version:

graylog-server is already the newest version (3.2.6-1).

I have run:

wget https://packages.graylog2.org/repo/packages/graylog-4.0-repository_latest.deb

dpkg -i graylog-4.0-repository_latest.deb
apt-get update &&  apt-get install graylog-server 

This is my list of packages:

dpkg -l | grep graylog
ic graylog-3.1-repository 1-1 all Package to install Graylog 3.1 GPG key and repository
ic graylog-3.2-repository 1-1 all Package to install Graylog 3.2 GPG key and repository
ii graylog-4.0-repository 1-2 all Package to install Graylog 4.0 GPG key and repository
ii graylog-server 3.2.6-1 all Graylog server

I have tried to remove the old version with: dpkg -r graylog-server, however when I run apt-get install graylog-server I am always getting the old version.

What am I doing wrong?

Thank you in advance for any help in resolving this one.

I have found a solution myself but I want to share in case somebody is experiencing the same issue.

Here is what I have done:

Edited /etc/apt/sources.list.d/graylog.list:
commented out the old entry and added this one:
deb [trusted=yes] https://packages.graylog2.org/repo/debian/ stable 4.0

Removed the old version:
dpkg -r graylog-server

Updated:

apt-get update && apt-get clean

Confirmed that apt could see the new version:

apt-cache policy graylog-server

Installed without any further issues:

apt install graylog-server

All working fine after that!

2 Likes

Ah, yeah. I was going to suggest this. The sources list file seems to biting a few folks right now. We might need to amend the docs to ensure that you remove the old repo first and then update to the newest.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.