Problem upgrading from 3.3.2 to 3.3.3

Hey all,
i have installed and configured graylog v3.3.2 and received a notification to upgrade to v3.3.3.
However i download the .deb package and trying to install it i get the below notification.
“graylog-server is already the newest version (3.3.2-1)”
I have ubuntu 20.04 LTS and ES version 6.8.10.
Is this a bug or compatibility issue?
thank you in advance

Why did you manually download .deb file… better way is to use official apt repository, so you can use simple commands to update graylog:

apt update
apt upgrade

How did you install graylog? Using official docs?

Hey, thanks for your reply.
I followed the official documentaion, that’s why. apt-get update are included laso in the documentation as you suggested but still no luck.

wget sudo dpkg -i graylog-3.3-repository_latest.deb
sudo apt-get update sudo apt-get install graylog-server

Check available packages in repo:
sudo apt-cache policy graylog-server

My installation shows 3.3.3-1 as a latest version

Check also installed package version:
sudo dpkg -l graylog-server

This is what I’m getting

$ sudo apt-cache policy graylog-server
Installed: 3.3.2-1
Candidate: 3.3.2-1
Version table:
*** 3.3.2-1 100
100 /var/lib/dpkg/status

$ sudo dpkg -l graylog-server
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
ii graylog-server 3.3.2-1 all Graylog server

Maybe you use some proxy server, that cache results, or mirror is not updated yet.

Unfortunately, in this case, I’m not using any proxy server.
Any other thoughts?

Hello, problem solved with the next update v3.3.4 following the procedure from the documentaion found here.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.