Issue with graylog updating process to Graylog 3.1.4

I am having a particular problem with updating my vmware OVA image graylog server to the newest version that came out which is 3.1.4. I have tried to follow the step-by-step that this docs page graylog provides:

I followed the first command which was “wget” and I believe it’s supposed to get the latest deb package.

I get this error every time I try to enter the command? I am wondering if the url has a typo?

I’m not sure how this solution came to me after I entered this command to troubleshoot installing a non-relevant command tool, but I was asked to take action if I wanted to install the newest package distributed, so then I just selected “n” for No since I thought it if I said Yes it would overwrite my graylog configuration file, so now it looks like I am on the newest version now?

I have a feeling this HTTP 404 error is a DNS settings problem I have on my server?

he @bholmes98

you did not share from what Version you upgrade from. You might need to adjust your Graylog server.conf with some settings.

The DNS Problems I can’t see on our end. If you are unsure about a status, you could always check our Status page on that:

Apologies, my graylog version was 3.1.3.

you do not need to install the repository packages for 3.1 if you just want to upgrade the 3.1 version to the latest stable bugfix release.

a simple sudo apt-get update && sudo apt-get upgrade should install the latest version.

Did you have tried that?

I believe it worked thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.