Unable to log in now! Error - the server returned: 404 - cannot POST - /system/sessions (404)


(foxj77) #1

Everything was working fine with my instance and then I tried to bind the graylog instances to the local IP address instead of the public IP address. I thought it was working ok as I was still able to hit the interface in the browser so thought my changes had worked until I i tried to log in and got the following error:

Blockquote

Error - the server returned: 404 - cannot POST http:// glg.myfqdn.com:9000/system/sessions (404)

I’ve tried to revert back all my settings to what it was but must of missed something as it’s still not working correctly.

From reading some of the posts on here and few other sites it sounds like issues with the api uri but haven’t been able to get it working. It was all working previously and thought i’d made all the changes back.

Here’s a copy of my config (with the domains and passwords changed):

https://pastebin.com/BUYpxS0t

Things were working previously before this change and have several servers posting logs into the setup and looked good. Just seem to have knackered it now trying to bind it to the local IP.

Thanks in advance


(Jan Doberstein) #2

as you use DNS Hostnames, maybe the Record has changed and did not point to the IP of that host.


(foxj77) #3

I’ve just cracked it after reading a few other posts on here. I had the web_endpoint_uri set wrong and was missing the /api/ at the end.

web_endpoint_uri = http://glg.mydomain.com:9000/api/

and then it was working again!


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.