404 on login - cannot POST to system/sessions


(Stu Campbell) #1

Hi,

I’m just getting started with Graylog. I spun up an AWS AMI for v 2.2.1.
At first when I went to the login page it was complaining that it couldn’t reach the private IP address, which makes sense. So I ran sudo graylog-ctl set-external-ip http://<external-ip>:9000 and reconfigured.

Now I get the login page but when I post, I get the error:

Error - the server returned: 404 - cannot POST http://:9000/system/sessions (404)

I can’t seem to find any config settings that are wrong. Any help would be massively appreciated.

Thanks

Stu


(Jochen) #2

I’m just guessing here, but I’m pretty confident that http://<external-ip>:9000 is not the address of your Graylog REST API.

See http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#configuration-commands for details.


(Jordan) #3

Getting the same issue but doing a manual install

Error - the server returned: 404 - cannot POST
rest_listen_uri = http://10.0.0.128:12900/
web_listen_uri = http://10.0.0.128:9000/

Any help?


(Jochen) #4

Please refer to http://docs.graylog.org/en/2.2/pages/configuration/web_interface.html and open a new topic if you’re still having problems after reading it.


(durga) #5

Hi,
I’m just getting started with Graylog. But i am unable to login.
I had used the instructions given in the web interface manual
But i am unable to login
web_listen_uri = http://127.0.0.1:9000/
rest_transport_uri = http://127.0.0.1:12900

please help me how to solve this
thank you


(Jochen) #6

Please open a new topic for your problem and add as much information as possible.

For example, 127.0.0.1 is the loopback address and can only be accessed from the very same machine but not from any other remote host in the network.


(Suresh Easwar) #7

Hi,
please try the below settings, it worked for me.

Keep web_listen_uri and rest_transport_uri same (http://localhost:9000/)
and keep rest_listen_uri and web_endpoint_uri same (http://localhost:9000/api)


(Jochen) #8

FWIW, that’s pretty much wrong 100% of the time.