Error - the server returned: 404 - cannot POST http://X.x.x.x:9000/system/sessions (404)


(Kunal2791) #1

Hi,
I’ve started to work with graylog. and wants it to setup for my company . i have followed graylog centos 2.3 document seems all fine but at login time. i’m getting blocked with the error

(Error - the server returned: 404 - cannot POST http://35.177.48.158:9000/system/sessions (404))
Please help me to short this out.


(Philipp Ruland) #2

Hey @kunal2791,

could you please post your configuration and the Graylog log-files? The level of information you gave is not helpful, if you want help :see_no_evil:

Greetings - Phil


(Kunal2791) #3

Hi Phil ,
Is there any way to upload .txt files. if please guide me.

and this is error screen shot

Regards,
Kunal


(Jochen) #4

My unscientific guess is that your web_endpoint_uri is wrong and that it doesn’t contain the public link to the Graylog REST API.

Please refer to http://docs.graylog.org/en/2.3/pages/configuration/web_interface.html for details.

You can use https://gist.github.com, https://0bin.net, or http://pastebin.com to upload text files and link them here.


(Kunal2791) #5

Hi,
here is a link for server.conf file

server.conf https://0bin.net/paste/W3pqCTXMm+w0CycR#1XxMKQes5ubISIo9+UJWbEFJK8sWN7TyGxX-EMyuU08)
for lo file
server.log
(https://0bin.net/paste/qQ3S0ELNQe0S7yk4#qcBPc+X-SvYPJOMQ+u6rdcFrPQBK3OfRDnOtx/Ec18Q)


(Jochen) #6

Your configuration file contains a lot of strange settings which are definitely not for Graylog.

I’d recommend taking a look at your web_endpoint_uri and generally to start with the default configuration file and only change the things you need to change (and know what they’re doing):


(Kunal2791) #7

Hi,
I’ve used the same conf file that you have attached and the only thing i changed is.
rest_listen_uri = http;//localhost:9000/api/ (127.0…0.1)
web_endpoint_uri = http;//publicip:9000/ (My Public IP= 35.177.48.158)
rest_transport_uri = http;//privateip:9000/api/ (My Private IP= 20.0.1.18)
web_listen_uri = http:;//privateip:9000/ (My Private IP= 20.0.1.18)
http and ip is separated by : not ; .

rest added secret password and root password.

but the error is still same. please suggest now.


(Jochen) #8

The Graylog web interface (i. e. your web browser) must be able to communicate with the Graylog REST API directly.
That’s not possible if you bind it to localhost (127.0.0.1).

Please refer to http://docs.graylog.org/en/2.3/pages/configuration/web_interface.html for details.


(Kunal2791) #9

Hi Jochen,
i have changed the localhost address to my private ip. as pubic ip is not working.
please suggest if i’m working.


(system) #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.