Unable to access both internal and external web

Hello to all,

I know this problem already not new and well documented but with many many tries i don’t no how to handle and fix my problem.
I anybody know how to do, i will be the happiest man in that forum.
If i set-up /etc/graylog/server.server.conf with :

Internal doesn’t work and external is ok…

If i put an # before :

http_external_uri = http://domaine.name.me:9000/

My internal works but nothing for external.
I read something for apache2.conf but it doesn’t work !!.

Any ideas ?
Thanks in advance.

Debian 10 buster
Elasticsearch 6.x
Mongodb 4.2
Graylog 3.2.0

why are you binding to are there multiple IPs on the machine?

what does domaine.name.me resolve to internally?

Sometimes it’s best to keep it simple.

bind to
and comment out your publish and external URIs

see if that connects… then start playing with the settings.

Because i don’t understand realy how It’s serve in this file.
I am french and all this things are not simple for me.
I try what you said and i will see.
My problem is nslookup is not allowed in my case because my provider forbid it.

I did it, internaly it works but externaly with both
Publish and external with comment i can’t access it.
It looks like somethings is wrong because part of my domain pass by the router but nothing append with port 9000 externaly.
I declare route for port 9000 to tcp 9000 inside my lan.

I think what you may need to do is setup an inbound NAT on your firewall to translate whatever the public address is for domaine.name.me to resolve to and then setup a port forward for that port as well. or simply allow inbound traffic on 9000 to However… if you are trying to get this setup as publicly facing, I would STRONGLY recommend using HTTPS and locking down the connection as much as possible. And if you can, leverage a front end in a DMZ, like NGINX to handle the connection.

It’s what i tried to explain.
My router is set to forward the external domain (the right one because this is not exactly this one for security reason).
I will try to access through my router and It’s not working, i don’t know why.
Because, my router is set as well as i can for all my needs, for example my other server are accessed correctly externaly.
Zabbix is one of them, i have 3 nas, all are externaly contactable.
I think my problem is only because my provider don’ t give me capabilities to resolve external domain internaly (nslookup).
Thanks anyway for your help and recommandations, https and dmz.

If you have it setup correctly for internal access, setting up for external access should be a simple matter, but beyond the general scope of this forum… you now seem to have a network/router/firewall/ISP issue. not a graylog issue.

I can’t imagine your ISP blocking nslookup, but it could be that you do have some sort of DNS issue going on. if you are trying to connect to your graylog via and it works internally, but you want to connect from outside via domaine.name.me, you need to make sure the internet knows that domaine.name.me is your public IP address so it can route the traffic to it. you’ll also need to setup either a port forward from 80 -> 9000 or allow access in on port 9000. If you want to access it as domaine.name.me from INSIDE your network, you’ll just need to setup either a hosts file on the system you are connecting from, or have a dns server with an entry for it pointing to

good luck

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.