Time not properly showed in generated PDF reports (graylog 3.1.x)

I use graylog enterprise (free license due to the low traffic) at my company and it became major part of our daily tasks.
There are daily reports sent via email in pdf format and i find it very weird that the PDF data is not very correct.
For example the time is 2 hours backward while the information is actual.

Quick values for all messages in the last 12 hours. The visualization represents data for query * in field **** and was calculated at Saturday 7 December 2019, 04:03 +0000.

I have searched and read almost everything about it but i wasn’t being able to find a solution on how to fix the time inside the PDF in order to show the local time instead of +0000.

In the configuration file i have the correct time zone.

fgrep timezone server.conf
root_timezone = Europe/Sofia

Can anyone more experienced tell me is there a way to fix this minor issue.
Thank you.

the root_timezone is just the setting /timezone that is used for the hardcoded admin user in Graylog.

Internally Graylog is using GMT/Zulu time for all actions. That is why the displayed time for the query is zulu time.

How should that behave in your opinion? What functionality should be given?

hi @jan,

Thank you for the information.
In my case the hard coded admin user was disabled because i am using LDAP (big thanks to the devs for that) which i find very very useful.
Anyway, i was wondering if it is possible to modify it somehow in order to display the time zone upon user settings, as i was able to see that each user can choose preferred time zone.

I am even okay if that modification is not possible. Guess after all it doesn’t matter that much if the PDF report will contain GMT or GMT+2 as long as the time is visible.

he @zay7sev

each user can decide what his timezone is in his own profile. Only the hard coded admin has his timezone hard coded …

I have opened an internal issue for that. As Reports are an Enterprise feature I do not have the option to open a public issue for that.

Hi @jan ,
Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.