Time configuration incorrect


(alexis) #1

Hello,

When I see the time configuration in Graylog, there is different time :

Capture

I see the graylog configuration file (/etc/graylog/server/server.conf), and the configuration is good :

root_timezone = Europe/Paris

When I doing the date command on graylog server the time is good

Thanks in advance


(Jan Doberstein) #2

please read and understand the comment above this setting in the configuration:

This is the time setting for the hardcoded root user, not the server. The server has always UTC as internal clock and will transform timestamp to the users profile setting timezone.


(alexis) #3

Yes I now but I don’t understand why the time is not good on graylog server.

Because when I doing the date command in server, I’ve this return :

ven. août 17 11:07:22 CEST 2018


(Jan Doberstein) #4

I guess you did not get it.

root_timezone is the timezone that the user admin - the default superuser - has. His profil is not editable, so you can’t set a timezone outside of the configuration file.

Graylog internally use UTC and display the time always as UTC not with the local time setting of the server.


Incorrect time in log
(alexis) #5

OK yes I’ve understand

But two days ago the three time in time configuration are the same


(alexis) #6

So I don’t understand why the Graylog server time is not correct


(alexis) #7

Because in the log in timestamp the time is not correct. It’s the same that the Graylog server


(alexis) #8

Do you have an idea ?

Thanks in advance


(system) #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.