Time Configuration


(Jonathan Julius Kayumbo) #1

Hi
My graylog is running in docker, i’m experiencing different Timezone
I have been reading about it and succeeded to change my graylog server timezone to EAT (Africa/Dar_es_Salaam) but User admin timezone is still running with default UTC timezone

Can you please help me out as the logs are coming in with wrong timestamp,

Thanks!


#2

You can change it from Users under System/Authentication edit the admin user and change the time zone accordingly.

Cheers,


(Philipp Ruland) #3

Heyo @JonathanKayumbo,

the timezone of the root user is set in the Graylog configuration file.

root_timezone = UTC
        The time zone setting of the root user. See this list of valid time zones. Default is UTC.

@hun That would work, but it’ll be reset the next time Graylog is restarted AFAIK :slight_smile:

Greetings,
Philipp


(Jonathan Julius Kayumbo) #4

Thank you man,
I had to create a new user with Administrator privileges and the set the time to my timezone and it worked
How ever i could not be able to edit the Administrator timezone , seems like it needs to be edited in back-end and i do not know how!


(Jonathan Julius Kayumbo) #5

Do you mind if you tell me how to locate this configuration file , as my graylog is running in Docker as a container :smile:


(Jan Doberstein) #6

you should read the documentation on this: http://docs.graylog.org/en/2.4/pages/installation/docker.html#settings


(system) #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.