This browser is a customized version of the great Swagger project

Hello Team,

We are using Graylog 4.2.7 and while accessing api browser we are getting below

As suggested here Graylog REST API
we are using chrome Version 105.0.5195.125 (Official Build) (64-bit) & even Firefox 104.0.2 (64-bit) but still gets the same window and unable to access

when checked the other api browser

it lists all the api but asks for password and it even after providing admin password it doesn’t work
can someone tell us how to get this done, either of the api will work for us

Please guide,

the message is not about your web browser but about api browser boundled with graylog, the problems logging in may be due to wrongly configured GRAYLOG_HTTP_EXTERNAL_URI or GRAYLOG_HTTP_PUBLISH_URI variables, i had problems with those when running graylog in docker

Hello Daniel ,
Thank you for your response, yes even mine graylog is running in docker as container, can you help us how you resolved this , is there any setting that can be enabled from UI or we need to add these settings in some configuration file.


just checked, had those broken because i don’t use the api browser, but fixed it by simply setting GRAYLOG_HTTP_PUBLISH_URI same as GRAYLOG_HTTP_EXTERNAL_URI worked, without it graylog sets its container’s internal IP as the api browsers url so it fails to download needed assets so it doesn’t work


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.