Set graylog FQDN for SMTP Gateway


#1

Hi,

i’m new with graylog and i playing with mail alert. But my smtp gateway does not let graylog send mail, because it does not send “HELO FQDN”.

I did not find where to setup my FQDN in graylog configuration. Someone can help me?

Thank you for help.


(Jochen) #2

#3

Hi thank you jochen,

i’ve already read this documentations, perhaps i’m missing something, but never find where to configure the fqdn of my server.

Here is my log :

The Graylog server encountered an error while trying to send an email. This is the detailed error message: org.apache.commons.mail.EmailException: Sending the email to the following server failed : my_smtp_gateway:25 (javax.mail.SendFailedException: Invalid Addresses; nested exception is: com.sun.mail.smtp.SMTPAddressFailedException: 504 5.5.2 <my_server>: Helo command rejected: need fully-qualified hostname )

Graylog juste present himself with hostname (my_server) and not fqdn (my_server.domain.tld)

Do you have an idea?


(Jan Doberstein) #4

did you use the OVA or did you install Graylog yourself?


#5

No i setup graylog on a centos server.


(Jan Doberstein) #6

you should check the configuration section @jochen has mentioned already:

If you had set everything matching your local settings.


#7

hi finally i found a settings which work :

transport_email_hostname = localhost

rather than

transport_email_hostname = my_gateway

thanks for help.


(system) #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.