Rsyslog only sending logs on restart

Currently running Graylog on Ubuntu; trying to send logs using rsyslog from another ubuntu server.
As of right now the connection is working, I am receiving logs through the input I have set up.
However, logs are only being sent when either the entire server or just the rsyslog service is restarted.
Is there a way that I can be receiving these logs periodically or in real time, and where would I edit these settings?

Thanks for any help or advice.

Hmmmm, that’s a bit bizarre. Can you include the information mentioned in Questions and You: A guide to getting an answer? It’d be helpful to see things like your syslog config, your input configuration, and know how much heap you have assigned to Graylog.