Password reset RHEL 7

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:
Old administration has a Graylog Server that cant be accessed. The new admins do not know the credentials to login via CLI or Web interface. I tried the reset using “e” but it still wants a username and password.

2. Describe your environment:

  • OS Information: RHEL 7

  • Package Version: Not sure

  • Service logs, configurations, and environment variables:
    cant access graylog to get logs.

3. What steps have you already taken to try and solve the problem?
I tried the reset using “e” but it still wants a username and password.

4. How can the community help?

Just need advice on how to bypass the username and password on the “e” screen. Not sure its even possible.

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Can you clarify what “e” means in this context?

If you can access and modify it, you can change the root (username: admin) graylog password via server.conf using the root_password_sha2 configuration parameter.

edit to add: if you are asking about resetting a RHEL password, that is unfortunately outside the scope of this forum.

1 Like

We were able to recover the root credentials and go into the serv.conf and change the password. Thanks for the response.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.