OVA continues to attempt to use port 587 despite being setup to use 25 using graylog-ctl script?


(bubba198) #1

HI everyone,

OmniBus packaged OVA continues to attempt to use port 587 despite being setup explicitly to use 25 by graylog-ctl script?

The error is below and it clearly shows that it is trying to use port 587:

The Graylog server encountered an error while trying to send an email. This is the detailed error message: org.apache.commons.mail.EmailException: Sending the email to the following server failed : smtp.x.x:587 (com.sun.mail.util.MailConnectException: Couldn’t connect to host, port: smtp.x.x, 587; timeout 60000; nested exception is: java.net.ConnectException: Connection refused)

How do I setup the OmniBus package if the script doesn’t work?

Thanks
~B


(Jochen) #2

Which commands did you run to configure the SMTP settings on the OVA and what was their output?


(bubba198) #3

Hi @jochen

sudo graylog-ctl set-email-config smtp.test.org --from-email=graylog@test.org --port=25 --no-tls --no-ssl

Thanks
~B


(marius) #4

Did you run

sudo graylog-ctl reconfigure

afterwards?


(bubba198) #5

Thanks @marius I did run sudo graylog-ctl reconfigure after the smtp command but it was still using the old port; finally I manually changed the config file and then run sudo graylog-ctl reconfigure again and this time it started using the legacy port 25 for SMTP.

At this point my issue has been resolved though not using the path one would expect to follow to arrive at the same place.

Thanks


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.