New Install on Centos7


#1

I installed Centos7, did the step by step up I got down to where there is verbiage about:
“To be able to connect to Graylog you should set rest_listen_uri and web_listen_uri to the public host name or a public IP address of the machine you can connect to. More information about these settings can be found in Configuring the web interface.”

I am assuming the above is for clients connecting for API. How do I access the Graylog to get to Dashboard or admin interface?


#2

I ended up changing the server.conf
added: web_listen_uri = http://10.2.0.71:9000/
systemctl restart gray

Still no joy.


(Jochen) #3

It’s for both, the Graylog REST API and the Graylog web interface.

What’s the hostname or IP address you’re using to access the machine running Graylog and what’s the complete configuration you’re using?


#4

2 LINKS IN A POST LIMIT!? WHY? So frustrated as I had nice reply I had to chop.

good to hear about the interface.
The only thing that has changed from default are:
the 2 password lines.
this:
web_listen_uri = [cant add link due to lame graylog policy]

I suppose when I use the API function, Ill want to change this:
rest_listen_uri = [LOOPBACK, cant add link due to lame Graylog policy]/api/

But like I said, I cant get to the portal interface to setup/administer.
What am I doing wrong?


#5

May seem like a dumb question, but do I need to install nginx or apache?


(Jochen) #6

If you’d properly format your post (e. g. use block quotes for your text snippets), that wouldn’t be a problem.
See https://community.graylog.org/faq#format-markdown for more information.


#7

Jochen, thanks for link and can review later.
I added tcp 9000 to FW and could get to the web interface. but got this error.
I disabled SElinux and FW and still get the same message.
I started the service, same deal.

Error message
Request has been terminated
Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.
Original Request
GET http://127.0.0.1:9000/api/system/sessions
Status code
undefined
Full error message
Error: Request has been terminated
Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.


(Jan Doberstein) #8

Did you read the message?

Original Request
GET http://127.0.0.1:9000/api/system/sessions

I assume that your rest_listen_uri is set to 127.0.0.1 which is the loopback device - and can’t be reached from any other device.


(system) #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.