Cannot reach web console on new CentOS 7 deployment


#1

Hello,

I’m installing Graylog (and have never used it before), and I’ve run into issues. I am installing on CentOS 7 and followed this guide to install Graylog 2.3:

http://docs.graylog.org/en/2.3/pages/installation/os/centos.html

After following the guild, I attempt to connect to the server via http://[server IP]:9000 but I get an error stating the site can’t be reached.

I’ve run a couple of checks to see if I can connect to various bits and they both produced content/valid connections:

curl -i -H ‘Accept: application/json’ (server ip address)

and

curl -i (server ip address)

Anyone have any suggestions? I’m not the most versed person with Linux and I’ve never used Graylog before, so it’s highly possible I’m missing something obvious.


(Jan Doberstein) #2

you should check your web_listen_uri and your rest_listen_uri because that guide - using the defaults - will have them listening on localhost only.

As written here:

To be able to connect to Graylog you should set rest_listen_uri and web_listen_uri to the public host name or a public IP address of the machine you can connect to. More information about these settings can be found in Configuring the web interface.


#3

Jan: I have already updated those and they’re both referencing the IP of the machine instead of localhost. Unfortunately that’s not the issue in this case.


(Jochen) #4

Please post your complete Graylog configuration file (with sensitive information redacted) and provide some details about your network setup.


#5

I’ve worked out the issue - user error on my part. I typoed when putting in the firewall exception into CentOS, so the port was still being blocked.

I’ve now got my ASA sending logs to Graylog successfully so all is good!


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.