Connection refused


(Jay) #1

I’m about at my wits end. I configured Graylog2 on CentOS 7 using: ttp://docs.graylog.org/en/2.3/pages/installation/os/centos.html & http://docs.graylog.org/en/2.3/pages/configuration/web_interface.html#configuring-webif

My old graylog server crashed and I rebuilt it with a larger storage capacity. On my test environment Graylog will connect and display fine on a system (this did have internet access) and once moved to our DMZ environment with zero internet access and no DNS, I can’t even connect to the Graylog Webpage. The IPs were changed from 192.168.1.150 to (fake public IP range we own) 150.150.150.150.

If do a Curl http://local_IP:9000/ the error is Cur: (7) Failed to connect to local_IP:9000; Connection refused.

If I set the local IP to 127.0.0.1 and enter a CURL command. I get the

My web_listen_uri: http://0.0.0.0:9000/api/
My rest_listen_uri: http://0.0.0.0:9000/

It works fine on my test environment, but fails in our dmz network that doesn’t have dns/internet access and it’s worked before with smaller capacity.

What am I missing?


(Jay) #2

Solved. Patience is the name of the game? No idea why, but it works now after not doing a thing.


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.