Multinode configuration MongoDB


(Steffen) #1

Dear all,

I am trying to setup a Multinode cluster existing of:
3 Elasticsearch Cluster Nodes
2 Graylog Input Nodes

The Elasticsearch-cluster runs already fine. The Problem is the second Graylog Node. I do not Need a MongoDB Replica, I just installed MongoDB on the first Graylog Node.

I now want to use MongoDB from my second node. Therefor I understood that I do not have to install MongoDB on the second node.

However, I tried several Things but I never get the second Graylog node visible in my Graylog Webpage -> Nodes :frowning:

I changed the IP in /etc/mongod.conf from localhost to Server IP - no success - Graylog did not even start anymore

How can I use the MongoDB from my first node in the second one?

I also created a user + PW on my first node and on the second I configured the following on my server.conf:

Authenticate against the MongoDB server

mongodb_uri = mongodb://graylogdbusr:PASSWORD@IPOFFIRSTNODE:27017/graylog

–>Nothing changed

I really appreciate your help!

Thanks in advance,
BR
Steffen


(Steffen) #2

Do you recommend to use a MongoDB replica on my two Graylog nodes? I think about that atm but I am very new to MongoDB…


(Jochen) #3

You don’t have to create a MongoDB replica set. A single MongoDB instance is okay, if you don’t want to have high-availability.

Please post the complete configuration and logs of your Graylog nodes and MongoDB.
:arrow_right: http://docs.graylog.org/en/2.4/pages/configuration/file_location.html


(Steffen) #4

Hi Jochen, thanks for your reply. I’ve had this issue since a week and tried so much things and read many articles. I just resolved that by my own by Setting the bindIP to 0.0.0.0. Now I see both nodes. Sorry for wasting your time. Please Close that Topic. Thank you!


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.