Modify graylog URL


I need to change the URL currently working from to This change works parcially, I am able to access

But System is replacing wrongly the URL:

The change in the config file to modify the URL is as follows:

# Default: http://$http_bind_address/
http_publish_uri =

# Default: $http_publish_uri
http_external_uri =

Do you know if other configuration has to be modified?


such is only possible with a proxy. not vanilla graylog

Thanks for your response Jan, you are always very helpful. Please let me explain further. I have the following configuration in the proxy:

 <Location /graylog>

When adding graylog at the end of the URL, I am able to get the correct URL with graylog at the end for Search, Streams, Alerts, Dashboards and Sources. For instance:

However, System option in main menu is getting twice graylog and then throwing 404 error for Page Not Found:

because the expected URL is the following:

Do you know why this behavior?


did you run 3.0.1? because that version should have a fix for that.

Thanks for your response Jan,

I am running 3.0.0. I will install Graylog 3.0.1 and check again.


Thanks Jan,

Graylog 3.0.1 fixed the problem as you mentioned.

Thanks for all your support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.