Graylog behind external reverse proxy


I am trying to configure Graylog behind an external reverse proxy - it is a feature built into our remote access system (RAS). However I dont know if it uses apache or nginx, are other reverse proxy methods compatible with Graylog?

I know the reverse proxy in the RAS only uses HTTPS (port 443), graylog only seems to have configurations for HTTP (port 80).

Lets say the normal URI to access Graylog is “” I have configured a second URI “” which points to the RAS system, which then forwards this request to “” (this is what the RAS guide says to do).

bind_address =
http_publish_uri =

However Graylog seems to be rejecting the incoming port 443 TCP packets.

I am running Graylog 4.1.14 on Ubuntu 20.24 (I know I need to upgrade).

Does anyone know what I am doing wrong? I would greatly appreciate any help, thank you in advance!

This page is somewhat verbose but has a lot of good info on it:

One of the most important things though is making sure you have the following 3 settings appropriately configured:

  • http_bind_address
    • This is the address that graylog will bind to, can be or a specific IP
  • http_publish_uri
    • this is the URI that graylog nodes use to talk to each other and should be the fully qualified domain name (FQDN) of the node (e.g. glnode1.domain.tld)
  • http_external_uri
    • This is the external public facing URL you use to access graylog web interface

Let us know if you have any specific questions.

Hey @Linedo

Graylog listens to port 9000, as for a reverse proxy you need to create a block with a proxy_pass
For example this is part of Nginx configuration.

erver {
  listen       *:443 ssl;

  ssl_certificate           /etc/nginx/ssl/fullchain.pem;
  ssl_certificate_key       /etc/nginx/ssl/privkey.pem;
  ssl_session_cache         shared:SSL:10m;
  ssl_session_timeout       5m;
  ssl_protocols             TLSv1.2;
  ssl_prefer_server_ciphers on;

  index  index.html index.htm index.php;

  access_log /var/log/nginx/ combined;
  error_log  /var/log/nginx/;

  location / {
 - - - 
- - - 

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.