Nginx proxy subdirectory graylog server


#1

Hello everyone,

I need help, i have a debian9, nginx 1.10.3 and Graylog server 2.5.0
i try to put a nginx reverse proxy in front of my graylog server.
this is my configuration of nginx:
location /graylog/ {
proxy_set_header Host $http_host;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Graylog-Server-URL htts://1.15.15.15/graylog/api;
proxy_pass htp://127.0.0.1:9001/graylog/;

    }

and this is my configuration of my graylog server:
rest_listen_uri = htt://127.0.0.1:9001/graylog/api/
#rest_transport_uri = http://1.15.15.15:9001/api/
web_listen_uri = htt://127.0.0.1:9001/graylog/
#web_endpoint_uri = htt://127.0.0.1:9001/graylog/api

and i think, i have already try everything, please help me :sweat::sweat:
thank you very much
(did not pay attention to “htt” in my config is http or https)


#2

i also have this error when i try to log on graylog:
Error: cannot GET https://1.15.15.15/graylog/api/streams (401)


(Jan Doberstein) #3

You need to have the following NGINX configuration

and rest_listen and web_listen setting


#4

hello,
thank you very much for your help, but it’s still doesn’t work :disappointed_relieved::disappointed_relieved:
this is my new configuration for nginx:
location /graylog/ {
proxy_set_header Host $http_host;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header Remote-User admin;
proxy_set_header X-Forwarded-User admin;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Graylog-Server-URL htt://$http_host/graylog/api;
proxy_pass htt://1.15.15.15:9001;

    }

and for graylog:
rest_listen_uri = htt://0.0.0.0:9001/graylog/api
web_listen_uri = htt://0.0.0.0:9001/graylog

and when i try to log on graylog i have the same error:
Error: cannot GET htt://1.15.15.15/graylog/api/streams (401)

(did not pay attention to “htt” in my config is http or https)


(system) closed #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.