License issues - moved to https?

Hi guys,

I am trying to update my graylog license file (using the free enterprise one) but the UI wont let me.
(giving me red banners reading ‘Could not retrieve license information’ whenever i try to type anything in the import-textbox or try to delete the old license file).

reading up in the existing posts here i found some similar posts but none really matching my case here.
I’m not (and have not been) using any proxy for connection outside.

the suspicious thing is, trying a
curl -v -XGET
returns a HTTP 301

querying the same URL via https works

maybe the checker doesn’t follow the 301 to the new location?
can i change the update url to https manually somehow?

Using GL 2.5.2 on debian btw

Just to clarify - you try to paste the new license code into the text field in the Graylog UI and receive an error?

What is the Enterprise Plugins Version you run? Does that fit to your Graylog version? Because both need to be the same.

yeah, any change event (e.g. typing) in that textbox causes the alert. So i dont think the licence is the issue.

Good question. Is there a quick way to find out plugin vs. server version?

Thanks jan, i think you hit the point straight on …

graylog-2.5-repository/stable,now 1-1 all [installiert]
graylog-enterprise/now 2.4.6 all [Installiert,lokal]
graylog-server/stable,now 2.5.2-1 all [installiert]

trying to update the plugin now

ok, tried to get and updated package and found some on this page:
installed and restarted server but still same messages on trying to update license

also I noticed that the “old” enterprise package is still there …
graylog-2.5-repository/stable,now 1-1 all [installiert]
graylog-enterprise/now 2.4.6 all [Installiert,lokal]
graylog-enterprise-plugins/stable,now 2.5.2-1 all [installiert]
graylog-server/stable,now 2.5.2-1 all [installiert]

do i have to manually remove the pkg? (did i even get the right updated package, as the naming is different?)

Complete removal of the enterprise plugin version(s) and then a reinstall did the trick.
and it solved the issue with the Licensing page - new License successfully deployed now.

thanks again.

One follow up though:

After i sorted out the licence thing I successfully upgraded via 3.0 to current 3.1 now finally.
Everything seems to be running fine on the new version, but a quick glance at the log file still shows license violation warnings in 5min intervals like this one:

2019-08-22T15:40:38.053+02:00 WARN [LicenseChecker] License violation - Detected irregular traffic records

Could this be because the system wasn’t able to do the remote checks for some time apparently and so we exceeded the 72 consecutive check failures that are allowed in the free license?

2019-08-22T15:40:38.053+02:00 WARN [LicenseChecker] License violation - Detected irregular traffic records

that is a warning - from a check where we tried to implement a detection if someone tamper the reportings … the wording is to harsh and the detection is not very good. Just ignore that. It does not mean anything.

Thanks Jan!

Thread can be closed :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.