Graylog3 Appliance

Hi all,
new with Graylog.
Download last version graylog-3.0.0-12.ova and deployed in a VW VirtualBox
Got this warning and applied solution:
If you don’t have a working DHCP server for your virtual machine, you will get the error message:

“Your appliance came up without a configured IP address. Graylog is probably not running correctly!”

In this case, you have to login and edit /etc/network/interfaces in order to setup a fixed IP address. Then create the file /var/lib/graylog-server/firstboot and reboot.

That is:
/etc/network/interfaces -->

auto eth0
iface eth0 inet static
address 192.168.x.x
netmask 255.255.255.0
gateway 192.168.x.1
pre-up sleep 2

Now, from my Google Chrome from my Windows, I try to access 192.168.x.x:9000 without success, always get access denied or not responding

curl -i 192.168.x.x:9000 also returns couldn’t connect to server if I modify server.conf with http_bin_address = 192.168.x.x:9000
With the 0.0.0.0:9000 default value, it respons to curl -i 127.0.0.1 with a 200, but not able to access to the web consol. What am I forgetting, please?

First make sure your NIC is up.
Please check output of
ip a

1 Like

I can see only lo: and enp0s3:
I didn’t know this command

sudo ifconfig eth0 up
: ERROR while getting interface flags: No such device :frowning:

If you run:

ip a

it will list and show all ip address associated on on all network interfaces:

1 Like

Your network interface name is enp0s3, replace eth0 with it:
sudo ifconfig enp0s3 up
The same in /etc/network/interfaces

1 Like

SOLVED. I should use NETPLAN.
Thanks to all!!!

New issue, not able lo login with admin/admin :cold_sweat:

neither with admin/yourpassword

Go back through https://docs.graylog.org/en/3.0/pages/installation/os/ubuntu.html#
Under Graylog and check redo you passwords.

I’m using OVA with graylog3, it is supposed to use admin/admin:

If using the VM appliance, log in using admin for both the username and password. If using either container or OS versions of Graylog, log in as admin and use the password from which you derived the password secret when installing Graylog.

Ok, solved reseting passwd. Thanks again

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.