Graylog2: Upgrade MongoDB to 4.0 Asserts User Count is High


(Greg Smith) #1

Hello All,
Just wondering if there is a work around, or solution to this problem that I don’t know about yet.

Problem: Server Status shows increase rate on Asserts User. How do I stop it from increasing or this is not a problem, just information?

Environment:
Graylog Server Version graylog-server-2.4.6-1.noarch
MongoDB Version mongodb-org-4.0.2-1.el7.x86_64
Elasticsearch Version elasticsearch-5.6.12-1.noarch

This is a standalone Virtual machine server.
10 VCPU, 10 GB MEM, and 500GB Drive

We use this Graylog server for testing upgrades and production improvements.
Last week I applied an Upgrade for MongoDB 3.6 to 4.0.

Execute the following documentation;
https://docs.mongodb.com/manual/release-notes/4.0-upgrade-standalone/

Monitoring MongoDB with Zabbix 3.4.14, Zabbix is using the following instruction to monitor Database as shown below;

Authentication is enabled on MongoGB, user as shown below;

No problems with the Upgrade, instruction went smooth as expected.
I noticed after an Hour from upgrading MongoDB Asserts User went from 0 and still climbing as shown below;

After digging around in the logs, I found that the script used for trending data on MongoDB was using credentials to log into Mongo. This was executing before with no problems.

I executed root# netstat -antup | grep -i 27017;

For testing purposes I stop using the script that Zabbix is executing and Yes the asserts user went down., but I have been monitoring for some time now, only after the upgrade on MongoDB has this started show more Asserts user count.

Any advice would be appreciated on why this might start happening.
Thanks in advance.


(Jan Doberstein) #2

it looks like your monitoring script is not closing the connection.

For testing purposes I stop using the script that Zabbix is executing and Yes the asserts user went down., but I have been monitoring for some time now, only after the upgrade on MongoDB has this started show more Asserts user count.

It does not look like Graylog is having any options into what you described. You should ask for help with the group that provided the monitoring script for MongoDB.


(Greg Smith) #3

@jan
Thanks you, I kinda figured it was but was not sure.


(Greg Smith) #4

@jan
I found the problem, and why it was working before.
I enabled Authentication in mongod.conf file AFTER the upgrade of MongoDB. Now the monitor script is using Credentials to log into database and like you said not closing connection. re-configuring the scripts to close connection.


(system) closed #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.