Graylog Web Interface Not working


(GT) #1

Just set up a new Graylog instance. All config etc is the same as other working instances, however when I navigate to the web interface I get:

We are experiencing problems connecting to the Graylog server running on http://Internal IP of The VM:9000/api/. Please verify that the server is healthy and working correctly.

You will be automatically redirected to the previous page once we can connect to the server.

Do you need a hand? We can help you.

Less details
This is the last response we received from the server:

Error message
Bad request
Original Request
GET http://Internal IP of the VM:9000/api/system/sessions
Status code
undefined
Full error message
Error: Request has been terminated
Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

There are no error messages in the log files, it just shows the normal startup process.

Anyone got any ideas as to why this isn’t working?

Cheers,

G


(Jochen) #2

Is http://Internal IP of the VM:9000/api/ the correct URI for the Graylog REST API and is it accessible for your web browser?

If not, you need to configure it correctly. See http://docs.graylog.org/en/2.3/pages/configuration/web_interface.html for details.


(GT) #3

A bit more context; this is not hosted on our network and we can connect to the API browser through the external IP address.

If the IP addresses in the config file for ‘rest_interface_uri’, ‘rest_transport_uri’ and ‘web_transport_uri’ are changed to anything other than the internal IP address of the VM, then we get even more issues with the result being that the web interface is completely inaccessible due to the JERSEY service failing to start with the ultimate error being ‘Cannot assign requested address.’

Cheers,

G


(Jochen) #4

There is no such configuration setting. I assume you mean rest_listen_uri.

The IP address in rest_listen_uri and web_listen_uri has to be an existing IP address on the machine running Graylog.

Try using the following configuration:

rest_listen_uri = http://0.0.0.0:9000/api/
rest_transport_uri = http://<Internal IP address of the VM>:9000/api/
web_listen_uri = http://0.0.0.0:9000/
web_endpoint_uri = http://<External IP address or hostname of the VM>:9000/api/

(GT) #5

Thank you for the reply, a colleague of mine sorted the issue.
Below you can see the lines of config we now have, the problem arose from the rest_transport_api being set to an internal address. When comparing to other GL instances, the two we compared to were both internally hosted so all three of these config settings were set to internal IP’s.

rest_listen_uri: InternalIP:9000
rest_transport_uri: ExternalIP:9000
web_endpoint_uri: InternalIP:9000

Cheers,

G


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.