Graylog doesn't listen sidecar collector port

My question seems similiar to Port 5044 is closed, cant get it open sidecar-collector windows
Graylog: 3.1
Filebeat 6.8.2
Sidecar: 1.0.1

I have Filebeat configured on a host, it’s in Running state according to Graylog Overview.
Collector configuration:

# Needed for Graylog
fields_under_root: true  
fields.collector_node_id: ${sidecar.nodeName}
fields.gl2_source_collector: ${sidecar.nodeId}

- input_type: log
    - /home/app/tomcat/logs/localhost_access_log.*.txt
  type: log
   hosts: [""]
  data: /var/lib/graylog-sidecar/collectors/filebeat/data
  logs: /var/lib/graylog-sidecar/collectors/filebeat/log

Even sidecar is in Running state I don’t see any message from it.
I believe the root cause of it that port 5045 is not listened and I don’t see any related errors in graylog.log
Sidecar log from host confirms it:

2019-09-03T14:59:11.754+0300    ERROR   pipeline/output.go:100  Failed to connect to backoff(async(tcp:// dial tcp connect: connection refused
2019-09-03T14:59:11.754+0300    INFO    pipeline/output.go:93   Attempting to reconnect to backoff(async(tcp:// with 65 reconnect attempt(s)

I’m sure it can’t be caused by port conflict, but anyway I also tried another ports.
Please advise what can be the reason and what are possible options to debug it.

did you create a beats input in your Graylog?

Follow System > inputs and create a beats input.

OMG, I really forgot this part, thanks a lot, @jan

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.