Beats input running, configuration for sidecar created but port 5044 is not open

Hello,
I am running on Windows docker container of Graylog 3.3 using docker-compose setting from documentation ( Version 4.0 does not come up).
I have been trying for the last two days to make sidecar beats to work but no matter what I try I get connection refused filebeat error(Sidecar connect properly and filebeats configuration is properly overwritten when I restart Graylog sidecar service).
I monitor port 5044 is not open:
image
Port 5044 is not blocked:
image

but input status look fine:
image
And configuration looks fine too:


Here is sidecar configuration:

Here is generated filebat configuration:
image

filebat log:

Can somebody help me to make this work?
That would be great help

Hello,

Maybe I can help.
From what I can see in you logs " Failed to connect".
Maybe to troubleshoot your issue have you tried to configure your Graylog INPUT as “Global”?
See if you get some type of a connection.

Hello GSmith,
Thank you for your suggestion - I tried it but it didn’t help.
The problem was the fact that port 5044 was not on the list of ports in graylog docker-compose configuration.
On top of that port 5044 is within the reserved range for Docker in Windows.
I used port 45045 instead and I added it to graylog cluster port list.
image

I hope that this post will help somebody in the future.
Thanks again,
Jerzy

1 Like