Graylog Docker Startup Default Logging Level

Hi Guy’s,

im using Graylog 4.0.15+a7bed0d with Docker. Im trying to figure out how i can modify the Startup Logging Level of Graylog. I can set it within the Webgui, but every Time i restart a Container, the setting is back to the default, which is in my case “Info”.

Best regards, hasturo

Hello @hasturo

Past couple months I just started using Docker /w docker-compose. I have found it pretty kool to work with.

I might be able to help since the past week or two I was trying to get log/s from the Graylog container.
What I did was the following to reconfigure my log level.

In the Web UI.

Then tail it…

docker logs -f <container_id>

EDIT:

I over looked this, I just tried it out and I have the same problem.

You can set it in this file.

check file /etc/graylog/server/log4j2.xml

https://docs.graylog.org/docs/manual-setup#supplying-external-logging-configuration

  <Loggers>
         <!-- RestAccessLogFilter -->
        <Logger name="org.graylog2.rest.accesslog" level="debug" additivity="false">
                <AppenderRef ref="RestAccessLog" level="debug"/>
                <AppenderRef ref="AUDITLOG" level="info"/>
        </Logger>
        <!-- Application Loggers -->
        <Logger name="org.graylog2" level="info"/>
        <Logger name="com.github.joschi.jadconfig" level="warn"/>
        <!-- Prevent DEBUG message about Lucene Expressions not found. -->
        <Logger name="org.elasticsearch.script" level="warn"/>
        <!-- Disable messages from the version check -->
        <Logger name="org.graylog2.periodical.VersionCheckThread" level="off"/>
        <!-- Silence chatty natty -->
        <Logger name="com.joestelmach.natty.Parser" level="warn"/>
        <!-- Silence Kafka log chatter -->
        <Logger name="org.graylog.shaded.kafka09.log.Log" level="warn"/>
        <Logger name="org.graylog.shaded.kafka09.log.OffsetIndex" level="warn"/>
        <Logger name="org.apache.kafka.clients.consumer.ConsumerConfig" level="warn"/>
        <!-- Silence useless session validation messages -->
        <Logger name="org.apache.shiro.session.mgt.AbstractValidatingSessionManager" level="warn"/>
        <Root level="warn">
            <AppenderRef ref="rolling-file"/>
            <AppenderRef ref="graylog-internal-logs"/>
        </Root>
    </Loggers>
</Configuration>

Hope that helps

To adjust mine, I execute this and reconfigured it manually.