Graylog AMQP input ssl rabbitMQ


(niged) #1

Hay All

I am trying to secure my connection between Graylog and rabbitMQ

My RabbitMQ config

 [
  {rabbit, [
     {tcp_listeners, [{"127.0.0.1", 5672}]},
     {ssl_listeners, [5671]},
     {ssl_options, [{cacertfile,"ca.crt"},
                    {certfile,"server.crt"},
                    {keyfile,"server.key"},
                    {verify,verify_peer},
                    {fail_if_no_peer_cert,true}
                    ]}
   ]},
      {log, [
         {syslog, [{enabled, true},    
                   {level, info},         
                   {identity, "rabbitmq"}, 
                   {facility, daemon}      
         ]}
      ]}

].

if i set “fail_if_no_peer_cert” to true, Graylog keeps failing to connect to rabbitMQ and i see in the rabbitMQ logs
i see “SSL: certify: ssl_connection.erl:400:Fatal error: handshake failure”

if i set “fail_if_no_peer_cert” to false it works fine

I have Read i need to add the certs to the keystore, but i done this and still no luck.

any help i be gratefull


(system) #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.