Graylog 4.3 Problem installing

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:

Installing Graylog on CentOS7 and get error when

sudo rpm -Uvh

file/folder doesn't exist multiple time

**2. Describe your environment:** 
* OS Information: Centos 7

* Package Version: 

* Service logs, configurations, and environment variables:

**3. What steps have you already taken to try and solve the problem?**

First got certificate error then
Tried --insecure 

**4. How can the community help?**
Can't get past above and also when I tried 

yum install graylog-server   it stated no package available

**Helpful Posting Tips:**  [Hold down CTRL and link on link to open tips documents in a separate tab]

It looks like they took “repo” out of the path. (@dscryber can help fix that in docs for now )

You can find all the packages here: Graylog Packages. Note that the most recent version of Graylog is 4.3 - probably best to grab that for new installs unless you have a reason for older versions.


Will do. Thanks @tmacgbay

Hello @twtepper
Just chiming in.
I’m kind of confuse, the title says Graylog 4.3 but the package is for 4.2. I see the docs are incorrect.

I have just installed Graylog 4.3 on CentOS 7 and Docker perhaps this will help.

  831  systemctl stop graylog-server
  832  sudo rpm -Uvh
  833  ls
  834  yum clean all
  835  yum update
  836  systemctl start graylog-server
  837  tail -f /var/log/graylog-server/server.log  

I am using the open version and I updated like you did and graylog would not start

I noticed some references to enterprise stuff when I issued

service graylog-server status

So i did this

yum remove graylog-enterprise-plugins

and it worked again


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.