Failed dependencies upgrading to 4.3.6

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:
I am trying to upgrade to 4.3.6 using the following commands (according to the documentation):
$ sudo rpm -Uvh
$ sudo yum clean all
$ sudo yum install graylog-enterprise

I get an error after the first command as follows:
error: Failed dependencies:
graylog-4.1-repository conflicts with (installed) graylog-4.3-repository-1-5.noarch
graylog-4.1-repository is obsoleted by (installed) graylog-4.3-repository-1-5.noarch

2. Describe your environment:

  • OS Information:
    CentOS 8.3.2011
  • Package Version:
    Graylog Open
  • Service logs, configurations, and environment variables:
    Everything is installed on one server

3. What steps have you already taken to try and solve the problem?
I googled the error and searched within this forum.

4. How can the community help?
I would like to know where to start so that I can resolve this issue and upgrade to the latest version. I am new to both GrayLog and Linux

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Here is a link from the @gsmith on upgrading with yum. It’s upgrading to your current version but it has better details than the documentation… which is typical of @gsmith. One of the points is to try:

yum upgrade graylog-server
1 Like

that worked great, thanks!

I now show that I am running version 4.3.11-1, but GrayLog says I am outdated and the latest version is 4.3.6.

Is that normal?

I think those messages are generated once they are valid and not taken away after the “issue” was solved. Ack them once, if they reappear we should check again.

Done, thanks for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.