Generic credentials window instead of web interface


I’m using Graylog 4x for quite some time now on my old server and I decided to give a try to the new v5.2.
I used the manual provided in the official documentation:

Every time I got through all those instructions, I’m ending up with generic login window instead of the web interface login screen.

No matter which password I use, it does not accept it and once I cancel the login I’m getting this error message:

You cannot access this resource, missing authorization header!

I tried with Ubuntu 22.04 and 20.04.

Config is very basic:

is_leader = true
node_id_file = /etc/graylog/server/node-id
password_secret = K8x0MGrYqCIVSLxc4CZjKeRHbjW-hxlq3dcI7N1r1TF2rEPY170Sg01IOMRRGpDbiB5nybe8rRm7k0I3wZkEvt8wGw5lQk--
root_password_sha2 = 1bf6c330a7df182cf2a6b9067bfd72377024737c249f2d811f6c13c44b868a3e
bin_dir = /usr/share/graylog-server/bin
data_dir = /var/lib/graylog-server
plugin_dir = /usr/share/graylog-server/plugin
http_bind_address =

Everything else is set to default.

I also tried with:

http_bind_address =
http_bind_address =

I also tried changing the ports, but nothing works…

I spent couple of hours on reading the forum and watching tutorials, but I always end up with the same login windows and not being able to sign in…

I’m going to bet that your server.conf is missing the elastic settings, see this doc for what should be there (for us on the elastic section) server.conf

So I should use Elasticsearch instead of OpenSearch?
The manual states that it’s better to use Opensearch:|Installing%20Graylog|_____3#Elasticsearch

No I would go with opensearch, elastic is nearing end of support. Opensearch was a fork of elastic, so they behave very similarly, and most of the settings in server.conf still refer to elastic, however the same settings work with both. So you will be configuring settings that say elasticsearch even when you actually have opensearch installed.p

I had the same problem as you and i finger it out with opensearch DB, the default config of "elasticsearch_hosts"is the problem

In server.conf try to use the same ip@ for “http_bind_address” and “elasticsearch_hosts” :

http_bind_address =

# Default:
#elasticsearch_hosts = http://node1:9200,http://user:password@node2:19200
elasticsearch_hosts =

this solution works for me



I was able to open the console after implementing your solution!

1 Like