Gelf.Extensions.Logging -> GrayLogDocker: no log records

I run the sample for NET Core:

Then I have ran Docker Docker — Graylog 4.0.0 documentation

Then I little bit corrected appsettings.json file:

{
  "Logging": {
    "Console": {
      "LogLevel": {
        "Default": "Debug"
      }
    },
    "GELF": {
      "Host": "127.0.0.1",
      "Port": 12201,
      "LogSource": "console-app-1",
      "LogLevel": {
        "Default": "Debug",
        "Microsoft": "Debug",
        "Gelf.Extensions.Logging.Samples.NetCore2": "Debug",
        "Gelf.Extensions.Logging.Samples.NetCore2.Program": "Debug"
      },
      "LogLevel2": {
        "Microsoft.AspNetCore.Mvc.Razor": "Error",
        "Default": "Trace"
      },
      "AdditionalFields": {
        "project_name": "my-project"
      }
    }
  }
}

Run the application, it works but when I go to browser
localhost:9000
I do not see any records.
What I do wrong? How to check the GrayLog logs about errors?

Hi there,

Can you provide your Graylog configuration. Do you have a GELF input listening?

Hi,
Ok, how to provide the configuration? what exactly?
I run the Graylog Docker using docker-compose file and >docker-compose up -d
and changed nothing.

There is from system inputs page

There are no global inputs.
There are no local inputs.

Thanx Aaron, you are right! I have added the global GELF Input and it works.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.