eMail not received when backlog is enabled

Good afternoon everybody,

My apologies is this has been addressed already, I went through previous topics but didn’t find the exact problem or solution.
I get email alerts no issues based on certain events collected through a Stream. Since I want to be able to get more detailed information (such source and messages) I found that I needed to set the Message Backlog to 1 in order to get that info in the email but I noticed that once I enable this I stop getting email alerts. It is worth mentioning the alerts still pop up when they are triggered, is just the emails wont get send if the Message Backlog is set to 1.

Thanks for your attention.

JF

Hello,
What version of Graylog are you using?
Did you add a notification template to your Event Definition?

I have GL 4.0.6 and here is an example of mine.



Hop ethat helps

Hi gsmith!,

Thanks for taking the time to answer. My Graylog version is 4.0.6+40b7be5, codename Noir.
I have a Notification templated added to the Event Definition, and as I mentioned in the OP, I do get alerts no problem except when I enable the Message Backlog. The reason why I need to enable this is because I want to include in the email a portion of the messages that trigger the alert.

These are my screenshots with the configuration that allows me to get email alerts.

@JFranco

Hello,

So if you tick that box for backlog you receive email alerts with no backlogs, or you stop receiving emails when you tick that backlog box?
Have you tried something like this instead.

image

EDIT:
What does the rest of your configurations look like (i.e. filter & aggregation or Summary)

Hi again!,

Sorry, I was going to add the other screenshot but as a new member it seems I’m only allowed to upload one image per reply.

Correct, if I thick that box I stop getting emails. I will be trying what you suggested.

Thanks!!!, what you suggested about disabling the Grace Period and just defining the Message Backlog worked!. I get emails with the backlog messages details I needed.

@JFranco
Thats Great glad it worked :slight_smile: