Dashboards hangs with loading message (2)

Hello,

I am able to see logs correctly in the search tab but I am not able to create a new dashboard.
When I create a new dashboard, I have a Loading message indefinitely.

I installed these plugins:
ii graylog-integrations-plugins 3.2.4-1 all Graylog Integrations plugins
ii graylog-server 3.2.4-1 all Graylog server

It’s to continue the discussion from this thread: Dashboards hangs with loading message

Thanks.

he @smutel

what browser did you use?

Hello,

I am using Firefox.

I tested with chrome. I have the same issue.

Hi @smutel,

can you please have a look into the server.log and also important a look into your Web development console. We are looking for some stacktraces which could explain this behavior.

Thanks a lot in advance.

- Konrad

Hello,

In the server.log, I have nothing.
In the web development console, I have this error:

I hope it will help you to troubleshoot this.

Thanks.

This is really strange, /api/system/pipelines/rule/parse seems to have a problem, but we do not call the API endpoint when creating a dashboard.

Do you have a Cluster, perhaps with different Versions of Graylog?
Did you upgrade or installed freshly?

Can you delete the cache by reloading the page with Ctrl+Shift+R ?

I am a little confused about this to be honest :smiley:

- Konrad

I have a cluster but the version is the same on each node (3.2.4-1).
If I remember correctly I installed the version 3.2.2-1 and updated to version 3.2.4-1.

I tried with a firefox in anonymous mode and I have the same issue.

Regards.

Hey @smutel,

could you please try again in following order:

  1. Click on Create Dashboard which should result in a loading Dashboard Page.
  2. Then open the webdev console
  3. then clear it like this:
  4. Then reload with clearing the cache Ctrl+Shift+R

And let’s have a look if we still are hitting, /api/system/pipelines/rule/parse

Also I would recommend updating to 3.2.5 now, since we fixed some hangers there. But there was nothing which is as you described, but who knows.

- Konrad

Hello,

I updated my graylog to version 3.2.5.
I cleared the web console I don’t see the error anymore but it still not working.

Two information:

  • I don’t have any error with the default dashboard called Sources
  • The loading issue is not when I create or go to custom dashboard. It appears when I choose one of relative, absolute, …

Regards.

Hi @smutel,

The loading issue is not when I create or go to custom dashboard. It appears when I choose one of relative, absolute, …

Can you be clearer here when the problem is occurring?

Also do you have by any chance any plugins installed?

Regrads,
- Konrad