Connected user ip address


(Marciofoz) #1

Hello friends!
When I check the connected users on User Accounts panel, I see only 127.0.0.1 (localhost), the panel dont show the correct ip address.

In my /etc/nginx/nginx.conf I have:

proxy_set_header Host $http_host;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header    X-Graylog-Server-URL https://log.server203/api;
proxy_pass          http://127.0.0.1:9000;

I miss some config value or need change another config file in graylog installation ??
Thank you by any reply.
Regards.


(Jochen) #2

Graylog will use the X-Forwarded-For HTTP request header if the proxy has been added to the trusted_proxies configuration setting (default is empty):


(Marciofoz) #3

Hi !
Works great!
Thank you.


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.