Cannot login GUI from LAN

Hi!

really noob here but I have graylog installed & running at Ubuntu 20.04 server.

I can login GUI with localhost:9000 (same pc than Ubuntu & graylog) but not able to log graylog from LAN.

Graylog pc ip-address is 192.168.1.60
LAN is 192.168.1.0/24

I’d like to allow all ip-addresses from 192.168.1.0/24 to log in GUI. No need from external ip (from WAN). What exactly I have to write to the server.conf?

Thx!

I think do you need to change the http_publish_uri and http_bind_address. Something like this:

http_publish_uri = http://192.168.1.60:9000/
http_bind_address = 0.0.0.0:9000

Hi!

Sorry to say but did not help…

https://docs.graylog.org/en/latest/pages/configuration/web_interface.html#configuration-options

Simplest thing to do to get it working is change the bind address to a valid IP address on the system. and comment out the http_publish_uri by adding a # to the front.

Make sure your system’s firewall is allowing connection on 9000 and you should be good

http_bind_address=192.168.1.60:9000
#http_publish_uri = xxxxxxxxxxxx (this will default it to using the bind address)

FYI you don’t need the http in the bind address.

My bad & fault… I was sure that I never enabled firewall to this ubuntu machine but still fw was enabled. Anyway after disabling fw everything is just fine. Sorry for bothering and thx for your help!

No sweat man… we’ve all been there and will again with something. Good luck