Not able to login using IP adress

I’m fairly new to this tool. I installed graylog on my linux machine but I’m not able to login using my IP address. I tried changing
1)http_bind_address =
2)http_publish_uri =
3)ttp_external_uri =
Not Able to find following lines in my server.conf
[is_master = true
node_id_file = /etc/graylog/server/node-id
password_secret = xxxxxx
root_password_sha2 = xxxxx
root_timezone = America/New_York
plugin_dir = /usr/share/graylog-server/plugin
rest_listen_uri =
rest_transport_uri =
web_listen_uri =
web_endpoint_uri =

Please describe more your problem. Which steps did you use to install graylog, which version, in which platform etc…

I followed Official documentation link :

when I change any line in server.conf file it stops hosting.

can you please help me with this issue.

  1. Please post lines which you have changed…
  2. Parameters like is_master, password_secret are situated at begining of /etc/graylog/server/server.conf file…

is_master = true
node_id_file = /etc/graylog/server/node-id
password_secret = J1rpiyFswuZyFuDwUgBTZqkWfZhWX0Nr6ThMUqtk7os6JRjJXemdCJsK4YHX2TkxidzvIIpLmDFvu1GJ
root_password_sha2 = 741f67765bef6f01f37bf5cb1724509a83409324efa6ad2586d27f4e3edea296
bin_dir = /usr/share/graylog-server/bin
data_dir = /var/lib/graylog-server
plugin_dir = /usr/share/graylog-server/plugin

are default with this server.conf I can login to graylog on (http://localhost:9000/) but not able to login using my “http://lIp_addrr:9000/”
So I tryed to changed different combinations of server.conf file as follows

  1. Default:
    http_bind_address = my_IP_Addr:9000
    2)http_publish_uri = http://my_IP_Addr:9000/
    http_external_uri = http://my_IP_Addr:9000/
    http_enable_cors = false
  2. also tryed both 1 and 2 combination
    but none of this work

I’m using Graylog versio v3.1.4+1149fe1

I want to monitor .net API on the server and it can not send the data. please help me to find the solution.

I was trying solutions given in following link but could not found any of the given parameters. Remote graylog website access (via internet, public IP)

Try to change:

http_bind_address =
http_publish_uri = http://my_IP_Addr:9000/
http_external_uri = http://my_IP_Addr/

Sorry, still not working.

Check if your firewall (on graylog or edge) doesn’t block connection to port http and 9000/tcp.
Try to telnet to port http, or 9000 if it works.

I already did that yesterday. I open the port 9000 for tcp and to all also check telnet connection it’s working fine.

Is there anything interesting in graylog log?

we are planning to use it to monitor and save logs of our .net API hosted on IIS server.can you suggest any other open source tool ?

graylog is great software for this kind of job…

You probably didn’t understand my question, I asked if there is some error messages in graylog log file, usually in /var/log/graylog-server/server.log

Hi, Thanks For the all the brother. just solved it. I have to enable cors for https.
and for binding I use as you suggested. Now it’s working.

Thanks Again.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.