Need help with installation


(Scott Keith) #1

I’m not overly adapt at using Linux. I am trying to get a single node setup done and when all is said and done I can’t get to the web portal. I don’t know how to check if graylog is actually doing anything.

My guess is that it’s something in the server.conf file but I’ve tried several different variations of what I think it may be asking for with no luck.

If my graylog server has an IP address of 192.168.1.150, I’m assuming that I’m going to enter something along the lines of http://192.168.1.150:9000/ or http://192.168.1.150:9000/api/ correct?

When I do that I get ERR_CONNECTION_REFUSED

I’ve checked my network firewall and that port is open to this machine. I can ping the machine from my desktop and I get a response.

In the server.conf file, using the 192.168.1.150 IP address, is that what I put in for the rest_list_uri and the web_listen_uri?

rest_listen_uri = http://192.168.1.150:9000/api/
web_listen_uri = http://192.168.1.150:9000

Root_username I haven’t changed.

For the hash password of the root user, what should I put in there? I ran the command echo -n yourpassword | shasum -a 256, but replaced the yourpassword with something else, for grins lets say password123. I have the hash and it all shows on one line. there are two spaces and then a - at the end of the line. Is that normal? Does the “yourpassword” need to be the actual password of the root user?

Scott


#2

Check this:

  • ps aux | grep graylog --> is the process running ?
  • netstat -laputen | grep 9000 --> is the service listening ?
  • less /var/log/graylog/server.log --> search error messages
  • iptables -nvL --> check if the TCP port 9000 is open
  • tcpdump -nni eth0 port 9000 --> debug network

(Scott Keith) #3

Yes, the process appears to be running.

When I enter the netstat line I get no results, it just takes me back to a command prompt.

No such file or directory on the server.log file

yes the port is open

tcpdump failed, no such device. I do have an ethernet controller listed, not sure why it isn’t eth0.

Scott


(Scott Keith) #4

Ok, I found the log, it’s /var/log/graylog-server/server.log

Couldn’t read cluster health for indices (could not connect to http://127.0.0.1:9200) – Although I’m not running a cluster

at java.net.URI$Parser.fail(URI.java:2848) ~[?:1.8.0_181]

ERROR [InputSetupService] Not starting any inputs because lifecycle is : Failed [LB:DEAD]

ERROR [ServerBootstrap] Graylog startup failed. Exiting. Exception was: java.lang.IllegalStateException: Expected to be healthy after starting. The following services are not running: {FAILED=[JerseySErvice [FAILED]]}


(Scott Keith) #5

I went back through the config file and noticed an error in the IP address. I’ve corrected that, rebooted the server, and can now get into graylog.

Thank you for the commands to look at the services and logs.


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.