Cannot include space in password for elasticsearch_hosts

I am attempting to connect to an elasticsearch cluster that uses native authentication. The password for the account that I am using has a space in it. When I attempt to start graylog the service errors out and I get the following message:

Caused by: java.net.URISyntaxException: Illegal character in authority at index 8: username:password@127.0.0.1:9200

I get the same error message whether I do:

elasticsearch_hosts = https://username:password with spaces@127.0.0.1:9200

or

elasticsearch_hosts = https://username:password\u0020with\u0020spaces@127.0.0.1:9200

as the documentation says:

This is the Graylog configuration file. The file has to use ISO 8859-1/Latin-1 character encoding.

Characters that cannot be directly represented in this encoding can be written using Unicode escapes

If I remove the spaces graylog does not error out, but then the password is incorrect. How am I able to include spaces in the password?

Have you tried quoting the string?

Unfortunately not. I tried the following variations with the same result:
“https…username:password@ip:port”
https…“username:password”@ip:port
https…username:“password”@ip:port

@perpetualstudent

consider this as a bug and please open a bug report over at github:

Until this is fixed you need to change the password to something without a space

Jan,
Thank you. I will do those things.