Can not get telegram-alert plugin working

Hi guys , after following:
Add the line ,docker-compose.yml line:
image: graylog/graylog:3.1
restart: always
- ./graylog/plugin/telegram-alert-2.1.0.jar:/usr/share/graylog/plugin/telegram-alert-2.1.0.jar
- graylog_journal:/usr/share/graylog/data/journal
Restartinf docker-compose…

Now , in GL web again , I can not see where is the telegram plugin.
1_ It is not listed under notifcations types.
2 _ It is not listed under plugins , under system/configurations
3 _ I can see telegram_alert-2.1.1.jar is properly listed in /usr/share/graylog/plugin folder , along with other .jar plugins.

-rwxrwxrwx. 1 root root 1.4M Apr 24 2018 telegram-alert-2.1.0.jar
-rw-rw-r–. 1 graylog graylog 3.6M Sep 12 14:55 graylog-plugin-collector-3.1.2.jar
-rw-rw-r–. 1 graylog graylog 21M Sep 12 14:56 graylog-plugin-aws-3.1.2.jar
-rw-rw-r–. 1 graylog graylog 5.0M Sep 12 14:57 graylog-plugin-threatintel-3.1.2.jar
drwxr-xr-x. 1 graylog graylog 20 Sep 13 12:54 …
drwxrwxr-x. 1 graylog graylog 38 Sep 25 16:27 .

I also change jar file to 777.

Shouls I enable the plugin ?
What can i do to check it ?

Did you checked if that plugin is loaded during startup? Did you checked if the Plugin version is compatible with the Graylog version?

Hello Jan, thanks for your response:
1_ Uploaded last plugin version “2.2.0” , that requires Graylog 2.0 or later.
Im using graylog ver 3.1. So versions compatibility should be ok.

2_checking if plugin is loaded during startup.
How can I do this check ? (Im using docker container version)
I can connect to container cli, but , can not find logs … and can not restart service from there.


I guess you used this one?

did you read the release notes on how to use?

You might want to search for docker logs and how to use that command to get your Graylog logs.

Dear Jan , im using this one.
After looking at portainer logs , I founded:
2019-09-26 14:25:39,062 INFO : org.graylog2.bootstrap.CmdLineTool - Loaded plugin: Telegram Alert 2.2.0 [de.sandstorm_projects.telegramAlert].

About release notes on how to use, I found:
“Please update your message templates to the new default template and set Parse Mode to HTML .”

But … again … can not find where to edit my “message templates” , and can not see “telegram alert” under notifications type.

I think , im close , please one more !!

as I do not use that plugin - I don’t know

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.