Admin timezone off from the root_timezone


(moire) #1

Hello,

I have noticed that under the search menu messages timestamp is different than the one the server is using. I double checked the root_timezone from the graylog.conf:

root@host-0:/opt/graylog# grep timezone conf/graylog.conf
root_timezone = Etc/GMT+3

but on the web interface I see:

Time configuration
User admin:
2017-08-28 05:25:33 -03:00
Your web browser:
2017-08-28 11:25:33 +03:00
Graylog server:
2017-08-28 11:25:33 +03:00

I see that the correct timezone GMT+3 is reflected on the Admin profile setting, but still the overview and messages timestamp have the wrong one. Any ideas or pointers? Thanks in advance.


(Jochen) #2

That’s completely correct.

The timezone “GMT+3” means that for example it reaches 10 o’clock 3 hours earlier than in GMT, so at 10:00 local time it’s 7:00 GMT. You probably want to use “GMT-3”, which means 10:00 local time is 13:00 GMT.

I agree that it’s totally unintuitive, but that’s how timezones work. Maybe use a specific timezone instead of a GMT offset, such as “Europe/Moscow”.

Check http://joda-time.sourceforge.net/timezones.html for a list of valid timezones.


(moire) #3

Thanks, it worked :slight_smile:


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.