Yet Another License violation

Hi,

I’m having trouble with License Violation.

I wasn’t aware about check features and didn’t configure proxy after installation, so license violation is actually here :confused:

  • [LicenseChecker] License violation - Failed to report license status to Graylog, Inc. - consecutive failures: 200, limit: 72

So i put correct values in server.conf for directives

  • http_proxy_uri = myproxy
    (and http_non_proxy_hosts for my node)

but still have the warn msg :confused:

for bash env i set proxy var for all profiles ==> OK to curl api.graylog. com

#curl -vk api.graylog. com/releases/active

  • About to connect() to proxy myproxy port 8080 (#0)
  • Trying 1.2.3.4…
  • Connected to myproxy (1.2.3.4) port 8080 (#0)

GET HTTP:// api. graylog. com/releases/active HTTP/1.1
User-Agent: curl/7.29.0
Host: api.graylog. com
Accept: /
Proxy-Connection: Keep-Alive

< HTTP/1.1 301 Moved Permanently
< Server: Cowboy
< Date: Thu, 27 Feb 2020 14:30:52 GMT
< Location: https:// api.graylog. com/releases/active
< Via: 1.1 vegur, 1.1 entproxy
< Content-Length: 0
< Age: 0
< Proxy-Connection: keep-alive
<

  • Connection #0 to host myproxy left intact

I tried a tcpdump to api. graylog. com but none packets appears when i restart graylog service as same with 443 port check except for admin gui

I have a duplicate entry also

2020-02-27T15:16:05.842+01:00 ERROR [IndexFieldTypePollerPeriodical] Uncaught exception in periodical
com.mongodb.DuplicateKeyException: Write failed with error code 11000 and error message ‘E11000 duplicate key error collection: graylog.index_field_types index: index_name_1 dup key: { : “graylog_0” }’

OS el7
graylog 3.2.0 with plugins packs

regards
julien
PS this is my first post so i have to play with links don’t look at links format…

Did you have your own jks ? Means a keystore for you self signed certificates? if yes check if that contains enough/the certificate to check let’s encrypt certificates that we are using for the API.

The mongoDB error is someething different.

Hi , thx for your quick reply, no we don’t use jks, i configure a nginx in front with proxy ssl (hosted on the same server) the cert in use is approved by our ca ompany.
regards

For informations i tried to disabled directives in server.conf and directly put proxy and port options in graylog jbm options as -Dhttp.proxyHost=myproxy…

I can see with ps jvm contains the right options but i didn’t see any traffic from my interface with tcpdump ^^ ? i can see trafic to proxy when i test api.graylog.com with curl but none when restarting jvm is it normal ?
regards

did you tried https with the curl command?

Yes there is no problem with curl and proxy envvar from shell. I tried /releases/active url with https and was able to retrieve informations
{“version”:{“major”:3,“minor”:2,“patch”:2},“suffix”:"",“codename”:“Ethereal Elk”,“released_at”:“2020-02-20T00:00:00.000Z”,“announcement_link”:“https://www.graylog.org/post/announcing-graylog-3-2-2","published”:true}

regards

Hi, i’m really sad :frowning: i have reinstall graylog…and everything fine except reporting license to graylog behind proxy.

2020-03-10T14:39:22.817+01:00 WARN [LicenseChecker] License violation - Failed to report license status to Graylog, Inc. - consecutive failures: 168, limit: 72

so…what could i do…

here 's my proxy config
#---------
http_proxy_uri = myproxy:8080
#have to add graylog server ip in non proxy hosts to avoid errors in logfile
http_non_proxy_hosts = my_graylog_ip
#---------

proxy env http_proxy and $https_proxy are fines and i could reach api.graylog.com but i could’nt find any trace with tcpdump when i restart graylog-server service …^^

could someone explain me why command above receive nothing even multiple restart of graylog ?

#tcpdump -i ens192 -v host api.graylog.com
tcpdump: listening on ens192, link-type EN10MB (Ethernet), capture size 262144 bytes

Any help will be appreciate.

regards
julien

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.