Graylog Enterprise LicenseChecker


(Daniel Schindler) #1

Hi all,

My test installation is complaining about “Graylog Enterprise License Violation”:

2018-02-13T13:25:54.072+01:00 WARN  [LicenseReportPeriodical] Unable to connect to license server: Verbindungsaufbau abgelehnt (Connection refused).
2018-02-13T13:30:53.846+01:00 WARN  [LicenseChecker] License violation - Failed to report license status to Graylog, Inc. - consecutive failures: 73, limit: 72

What URL is it trying to connect to? Can I configure proxy settings somewhere for the LicenseChecker?

Regards,
Daniel


License violation message
(Jochen) #2

If settings http_proxy_uri in the Graylog configuration file doesn’t work. try setting the http.proxyHost/http.proxyPort and https.proxyHost/https.proxyPort system properties in the JVM settings of your Graylog installation.


(Jan Doberstein) #3

you could set the proxy in your server.conf

the URL that is requested is https://api.graylog.com/report

regards
Jan


(Daniel Schindler) #4

Thanks for the quick response guys :slight_smile:

I have to use basic auth for the proxy so I didn’t get it working via the http_proxy_uri in the server.conf. Is there a special format to use when proxy-basic-auth is required?

I added th following default java options for the JVM:

GRAYLOG_SERVER_JAVA_OPTS="... -Djdk.http.auth.tunneling.disabledSchemes= -Dhttp.proxyUser=user -Dhttp.proxyPassword=password -Dhttp.proxyHost=myproxy -Dhttp.proxyPort=8080 -Dhttps.proxyUser=user -Dhttps.proxyPassword=password -Dhttps.proxyHost=myproxy -Dhttps.proxyPort=8080"

But I still keep getting:

2018-02-13T21:38:56.046+01:00 WARN  [LicenseReportPeriodical] Unable to connect to license server: Failed to authenticate with proxy.
2018-02-13T21:43:55.889+01:00 WARN  [LicenseChecker] License violation - Failed to report license status to Graylog, Inc. - consecutive failures: 85, limit: 72

(Daniel Schindler) #5

Does anyone else have an idea what I can change so that the communication via the proxy works? yum for example works flawlessly over the proxy.

Any help appreciated :blush:


(Jochen) #6

Please create a bug report at https://github.com/Graylog2/graylog2-server/issues if the proxy settings aren’t working for you.


(Daniel Schindler) #7

Thanks Jochen. I created a corresponding bug report


(system) #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.