Webinterface assets address


#1

So this is probably a rookie question, but been trying for a while now and i just dont understand what i need to change to get graylog on docker to work.

So i have graylog/elastic/mongo running in docker on another machine on my local network. It seems to be starting fine, and im able to get responses from the REST api just fine. However when navigating to 192.168.10.99:9000 (the address of the server running the docker instance) i get response from the initial request (So i get the HTML index file) however inside said index.html file all the assets (config.js/app..js/etc) got the address of the docker container (http://172.26.0.4:9000/config.js - in my case) And as im not able to connect to this address it doesnt work. config.js does exist on 192.168.10.99:9000/config.js however. So im wondering where this address is taken from? And if i can change it? is it not possible for it to use it’s relative path? i assume there is a reason that i do not yet fully understand

Thanks for any help

EDIT:
So i did manage to figure it out, why does it always happen that you find the solution just after posting for help hehe. The setting i was looking for was “http_publish_uri” or “GRAYLOG_HTTP_PUBLISH_URI” in my case :slight_smile: if anyone got the same issue in the future


(Tess) #2

There’s a very good explanation for it :slight_smile:


(system) closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.