Cannot access docker graylog web


(Szymon Stasik) #1

Hi there!

I found few similar questions with no real answer - the closest one is this: Cannot get web admin to work

I’ve tried both graylog 2.5 and 3 with same results - most of the time the HTML contains references to urls containing internal docker ip instead of relative ones or with external address. What’s interesting it randomly works - once per 10-20 requests (or docker compose restarts - hard to say). I tried various variables for GRAYLOG_WEB_ENDPOINT_URI, GRAYLOG_REST_LISTEN_URI, GRAYLOG_WEB_LISTEN_URI without real success.

Wonder if there is any reliable solution for this? I am using docker-compose file from the settings running docker containers inside VPS with external IP and domain name assigned.

Regards!
Szymon


(Szymon Stasik) #2

one workaround (which actually makes a lot of sense) is to add to a docker-compose.yml a openvpn instance and then reach out directly to a docker ip to talk to graylog

still I am curious to know if its possible to start the docker compose and access it from outside


(Jan Doberstein) #3

In my lab environment I have used NGINX to proxy that:

And in the Documentation given docker-compose file you only need to adjust one setting. GRAYLOG_WEB_ENDPOINT_URI to be the URL that is reachable by your Webbrowser.

http://docs.graylog.org/en/2.5/pages/installation/docker.html#persisting-data


(system) closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.