Upgrade options for Graylog Enterprise 4.2.5 running on arm64

1. Describe your incident:
Hi all, requesting your advise and inputs regarding upgrade options for Graylog Enterprise 4.2.5 on arm64.
I have this notification every few hours " You are running an outdated Graylog version. The most recent stable Graylog version is 4.2.8 (Noir) released at 2022-04-12T00:00:00.000Z "

Based on what I looked up, the last release of Graylog-enterprise for arm64 was 4.2.5

2. Describe your environment:

  • OS Information:
    Graylog Enterprise 4.2.5 running as a containerized app within docker, on arm64 platform.
    I;m using docker-compose.yml file to define the Graylog environment/startup parameters, as well as been using it to perform upgrades (through tags)

  • Package Version:
    4.2.5

3. What steps have you already taken to try and solve the problem?
Based on the available tags for arm64 ( graylog/graylog-enterprise Tags | Docker Hub

  • the last Graylog release was 4.2.5 about 4 months back
    All subsequent releases (4.2.6, 4.2.7 , 4.2.8) have been releases ONLY for amd64.

Now I do see 4.2.8 released both for amd64 & arm64 - but this I presume is the OSS graylog image and NOT the enterprise image graylog/graylog Tags | Docker Hub

4. How can the community help?

Please advise if here are any upgrade options available for Graylog Enterprise on arm64 post release 4.2.5.
Thanks for your time

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Hello,

Where are you seeing this Message?
After updating Graylog did you restart the service?
If this message is shown on the Web UI try refreshing the browser or logout and back in.

Hi - thanks for replying.
Yes - this notification message appears every few hours in the Web UI.
I already tried taking down the container and bringing it up a few times, that didn’t help.

As you mentioned, I switched from Edge to Chrome to Firefox (cleared all cache and history everytime), but the notification followed across all 3 browsers.

Can I ask how did you perform an upgrade?

I’m sorry I should have stated clearly - there was no upgrade performed in the recent past. The last upgrade if i remember was around Jan-Feb 2022 from 4.2.4 to 4.2.5, after which I’ve been using Graylog intermittently.
The notification in WebUI asking to upgrade to 4.2.8 started appearing about from last 10-12 days, but there is no enterprise image for arm64 released after 4.2.5 (from what I could find off graylog/graylog-enterprise Tags | Docker Hub

So thats where I’m a but puzzled - why is it even asking me to upgrade when there is no public image 4.2.8 image available for arm64,
Or maybe I’m missing something.

I understand now…

I’m not sure, this is very odd. Only thing I can think of is that they are using the same image for Graylog/Graylog Docker below for the enterprise version so that why your getting a notification.

The only difference between Graylog Enterprise and Community version would be the plugins that I know of. Once you get the license for the enterprise version, it opens up all the modules needed. So with that said, the Docker Enterprise container has very thing you need to run the Enterprise version.
This is just a just a guess from what I have seen.

I have Docker with Enterprise version and 25 Graylog open instances . I run them on multiple
OS’s like Ubuntu, Rocky Linux, CentOS 7-8, RHEL, Fedora, AlmaLinux, and Debian.
So far I haven’t run into this issue yet.

EDIT: I just upgraded my container from 4.2.5 to 4.2.8
Steps taken

Get new image
docker pull graylog/graylog:4.2.8-jre11

Edit docker-compose.yml file
vi docker-compose.yaml

Changed image

graylog:
    image: graylog/graylog:4.2.5-jre11

To

graylog:
    image: graylog/graylog:4.2.8-jre11

docker-compose up -d --build

Refreshed Browser tab and that was it.

EDIT#2:

I did some more testing on graylog/graylog-enterprise image.
So my assumption was right. The enterprise image has the needed plugins.
I installed it by using this below.

root@ansible:/home/greg# docker pull graylog/graylog-enterprise:4.2.8-1-jre11
4.2.8-1-jre11: Pulling from graylog/graylog-enterprise
c229119241af: Already exists
2f1dc05f270b: Already exists
39b2c24c052e: Already exists
e94fd7d3bf7a: Already exists
f13c89cc1617: Pull complete
9d949e259bbe: Pull complete
30d5d65bd15e: Pull complete
30d647ca0fbc: Pull complete
Digest: sha256:2b70e5686107e7bedf636b9f1d139e686cc31918ba262cfc856a49c40b2bfb08
Status: Downloaded newer image for graylog/graylog-enterprise:4.2.8-1-jre11
docker.io/graylog/graylog-enterprise:4.2.8-1-jre11
root@ansible:/home/greg# docker images
REPOSITORY                                          TAG             IMAGE ID       CREATED         SIZE
graylog/graylog-enterprise                          4.2.8-1-jre11   7a2b09b711a7   3 weeks ago     746MB
graylog/graylog                                     4.2.8-jre11     eaee8e1326ba   3 weeks ago     507MB
mongo                                               4.2             a2724a851733   8 weeks ago     388MB
mongo                                               4               0450bd78d2c1   8 weeks ago     438MB
graylog/graylog                                     4.1-jre11       b145836fe67f   2 months ago    874MB
graylog/graylog                                     4.1             164480a751bc   2 months ago    841MB
graylog/graylog                                     4.2-jre11       cd692241e0db   2 months ago    507MB
graylog/graylog                                     4.2             dc69f84dedbd   2 months ago    473MB
mongo                                               3               2f21415cb85f   12 months ago   453MB
docker.elastic.co/elasticsearch/elasticsearch-oss   7.10.2          b313026e6fbd   15 months ago   699MB
docker.elastic.co/elasticsearch/elasticsearch-oss   7.10.2-amd64    b313026e6fbd   15 months ago   699MB
root@ansible:/home/greg#

Then add my image (4.2.8-1-jre11) as shown above to my docker-compose.yml file.

I had to go here to find out why

That’s all I got for ya.

Thanks, that’s quite a detailed guide, appreciate all your time. I’ll try to replicate the steps.
Just one question - you upgraded for linux/amd64 or linux/arm64 platform?

Hello,

I’m using linux/amd64.

I did find something out today.
After upgrading the image Graylog/Graylog to 4.2.8 I didn’t have problems , But changing my image to Graylog/graylog-enterprise I found that my for enterprise plugins were gone.
Seams weird but I have checkpoint made so I’m rolling it back and found out why this has happened.

Aah, I See.
My platform is linux/arm64 and unfortunately it didn’t work out for me.
I tried to replicate your steps - the docker commands did pull down the images (JRE 4.2.8 and Graylog 4.2.8) , and then I edited the docker-compose.yml file to update the tags , but the upgrade still errored out with the message something on the lines "No image could be found ".
And I figured out why - I didn’t specify the arm64 tag when pulling down images through docker, so it got the linux/amd64 images , but these obviously then couldn’t be used for upgrade as I’m on arm64 and docker-compose.yml file references the arm64 tag in image name.
So that didn’t go as planned :frowning:

I guess I’ll just live with the upgrade notification , until the arm64 enterprise images are released.
Thank you sir, I appreciate all your time and effort trying to help me through with this.

Hello,

actually you mention that but i forgot. My apologies.

You could post you issue here, maybe something is up with that image.

Sorry I can be more help,

Hello,

Just realize a new version came out 4.2.9 9 hours ago :laughing:

Take a look here this is for Linux/amr64 image.

Yeah, Some reason the Linux/arm64 architecture does not have enterprise newer version. It looks like only for Linux/amd64. I would highly suggest posting on GitHub ask why and how-to on the notification about updating a new version.

Oh…ok.
Sure, would do that then. Thanks