Upgrade 1.1.4 to 2.2


(Alberto Frosi) #1

Hi all,
can you give some good advice to update my graylog version?
I know my graylog version it’s a pretty old.
Thanks
Alberto


(Jochen) #2

Upgrading directly from Graylog 1.x to Graylog 2.2.x is not supported.

You can try upgrading every minor version step by step (e. g. Graylog 1.1.x → 1.2.x → 1.3.x → 2.0.x → 2.1.x → 2.2.3), but at some point it might be easier to start from scratch.


(Alberto Frosi) #3

Ok jochen , but can I keep at least my ES and mongo db instaces and install the lastest graylog version ? Or is more easy install all from scratch and export / import my data?
Thanks
Ciao
Alberto


(Jochen) #4

Graylog 2.x requires Elastiscearch 2.1.x or later. You need to upgrade your Elasticsearch nodes.

See http://docs.graylog.org/en/2.2/pages/upgrade.html for details.