Updating OVA from 2.2.3 to 2.3.1 fails when running "sudo graylog-ctl reconfigure"


(Jamie Parris) #1

I tried to perform an update to the GrayLog OVA. I have not done anything special to the OVA, and updates have went through without a single issue in the past. The only thing that might be different is that I did add the geolocation to the system. Here’s a screenshot of what I am seeing during the reconfigure execution.


(Jochen) #2

That’s etcd failing to start after the upgrade.

Please refer to the following GitHub issue for more details:


(marius) #3

@Sparky on a fresh 2.2.3 installation the update process works fine to 2.3.1. Do you remember the history of that installation so that we could try to reproduce the upgrade path you took?


(Jamie Parris) #4

Hey Marius. I am unsure as to what version we started with, but we have updated this server 4 - 5 times if memory serves correctly. I will see if I find something that shows at least a date when it was installed initially which would let you know what OVA version I started with.


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.